Help: Twitter Widget not Working

LaggyGamerz
@LaggyGamerz LaggyGamerz

EDIT: Apparently people are still reading this thread, so I'll try to summarize it. We resolved this problem for ourselves by adding the domain to a whitelisting field. However, it seems like they've removed this feature from the widget settings, the widget no longer asks for domains.

If you're still having problem, you may want to try adding a "http://" or "https://" to where it refers to the javascript (e.g "//platform.twitter.com/widgets.js" -> "https://platform.twitter.com/widgets.js").

Best of Luck!

ORIGINAL:

Howdy,

I cant get the Twitter Widget to display on my site. I tried putting it as part of the content, making an .html file with the code on the website and the same locally. cant get it to work. All it displays is a link with "Tweets by @LaggyGamerz"

Here is the code:

  1. <a class="twitter-timeline" data-dnt=true href="https://twitter.com/LaggyGamerz" data-widget-id="245188795572568064">Tweets by @LaggyGamerz</a>
  2. <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
1 year 32 weeks ago

Replies

LaggyGamerz
@LaggyGamerz LaggyGamerz

Nvm, fixed issue. Problem was with domain (www.domain.com vs domain.com)

1 year 32 weeks ago
twigcreative
@twigcreative Twig Creative

where are you entering these domains? i have no idea.

1 year 3 weeks ago
LaggyGamerz
@LaggyGamerz LaggyGamerz

Same place you create the widget and generate the embed code: https://twitter.com/settings/widgets

1 year 2 weeks ago
Webkilde
@Webkilde Webkilde.no

This is ridiculous... Where do you enter this??? There is no such option in the widget editor! :( I've spent the last 5 hours trying to make this work and I am so massivly frustrated now.

1 year 2 weeks ago
OhHowSuper
@OhHowSuper Super natural

They have removed domains, you have to edit it inside your javascript,

I've got it working for android but no luck for iphone

I have no idea what to do..

1 year 2 weeks ago
ImmuneInctv
@ImmuneInctv ImmuneInc

How did you edit in the javascript? I can't find a version of the widget.js that isn't a compressed version and I see no field in the original embedded script that gives access to a domain.

1 year 2 weeks ago
OhHowSuper
@OhHowSuper Super natural
  1. <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>

It's the js.src, for some reason the domain is "//platform.twitter.com/widgets.js"

I changed this to "https://platform.twitter.com/widgets.js"

Again works for android but iphone is a no joy

1 year 2 weeks ago
apurva_bansal
@apurva_bansal Apurva Agrawal

@OhHowSuper have you resolve this issue because I am facing same issue with ipad & iphone. things are woking fine for android not for ios.

2 weeks 1 day ago
apurva_bansal
@apurva_bansal Apurva Agrawal

Any one having this issue with ios because it is not giving twiiter timeline on same page instead it open a new web page and show timeline there any one here can help me with this?????????

2 weeks 1 day ago
JamKoForce
@JamKoForce JamKo Force Networks

If you are using a CMS such as joomla, your editor is the problem. It is stripping out the new javascript code. I can't speak for wordpress, but in joomla, I just chose "no editor" for my user, and then pasted in the code, exactly as it is from the twitter widget, applied it, saved it, checked my live site. Good to go.

45 weeks 1 hour ago
velascoritche
@velascoritche VELASCO RITCHE

why red the color of the other leters of my twiter?

46 weeks 2 days ago
CariCreates
@CariCreates Cari Creates Designs

I tried entering my domain both ways, and still have only the "Tweets by" heading showing up - no feed at all.

1 year 30 weeks ago
christonacamel
@christonacamel some guy

There doesn't seem to be a solution and Twitter won't respond. Tweet @twitter using this hashtag #widgetprobz. I'm hoping that if enough people complain they'll do something about it.

10 weeks 2 days ago
AP_THE_REBEL
@AP_THE_REBEL Andrew P

im having the same issue embbeding the widget in my page www.rebelandrewp.com instead of a widget its just a link that appears tweets about ''rebel andrew p'' i like to use this widget feature, help would be appreciated thanks

1 year 30 weeks ago
cozmicsoulfire
@cozmicsoulfire ☆♫♪MarianneVedder♪♫☆

I am having the same problem that the widget does not show at all placed as a html widget on my site cozmicsoulfire.com first showed that favorite tweets@cozmicsoulfire link now not even that :(

1 year 30 weeks ago
UTheos
@UTheos Universal Theosophy

Similar issue here. I created the twitter widget with two domains, one is our main site, the other is facebook (for our facebook page). Widget shows up fine on our site, but doesn't show up on the facebook page tab (all I see is "Tweets by @UTheos").
On our site (right column, scroll down): http://www.universaltheosophy.com/
On our facebook page: http://www.facebook.com/TheosophicalPath/app_208195102528120

Same widget.

1 year 30 weeks ago
froginthevalley
@froginthevalley Sylvain Carle

Check your javascript console for error messages.

1 year 30 weeks ago
theo_wdfb
@theo_wdfb Theo

I've got the same problem. Noticed that widgets.js doesn't load.

1 year 27 weeks ago
JayStevesPro
@JayStevesPro Joe Carroll

I'm having the same problem. The widget is displayed when I access my site from a PC using Google chrome. However, when I access my site from any Mac, my iphone, or my google nexus 7 the space where the widget is supposed to show up only displays the text "Tweets by @Mytwittername"

Here is an example of what it looks like, notice the blank space on the right side: http://s11.postimage.org/6d6fn9itt/twitterwidget.png

1 year 29 weeks ago
TenancyServices
@TenancyServices TenancyServices

Like every one else, all I get with the timeline widget (IE & Chrome) is "Tweets by @TenancyServices". http://www.tenancyservices.co.uk/pages/twitter

I have both www.tenancyservices.co.uk & tenancyservices.co.uk in the whitelist. When I add tenancyservices.myshopify.com (it's original address) to the whitelist, it reports an error "unable to update your widgets, please check your inputs".

The widget doesn't only not work on my site, even the preview on the widget configurator fails to show.

1 year 29 weeks ago
CivicCenter
@CivicCenter SFCivicCenter

The old widgets worked great and now the news ones don't work at all. I've tried every suggestion here. Very annoying.

1 year 27 weeks ago
WorldFootprints
@WorldFootprints World Footprints

Has anyone found a fix? My developers are pulling their hair out. The failure to load tweets to our website halted abruptly.

1 year 27 weeks ago
belize_guide
@belize_guide Belize Travel Guide

Having the same problem on my site but actually hate this new feature as I only want to show the most recent tweet on my website, not recreate twitter on my own site. Will probably have to take the twitter feed off completely - shame as it used to work perfectly!!

1 year 26 weeks ago
StefanoLindt
@StefanoLindt Stefano T Lindt

Has anybody found a solution? It still not working...

1 year 26 weeks ago
thri1l
@thri1l robin

i had the same problem.
the error was caused by the extension "antisocial"

1 year 24 weeks ago
pfathens
@pfathens Pavlos

Had the same problem and it worked for me!

What you have to do is to add one EXTRA domain name on the "widget configurator" section (settings->widget->"your selected widget"->domains), e.g. if you had "domain.com", type in "www.domain.com" (separate with comma).

Thank you @LaggyGamerz for the tip.

1 year 24 weeks ago
podcastcompany
@podcastcompany The Podcast Company

worked for us - thanks!

1 year 22 weeks ago
twigcreative
@twigcreative Twig Creative

i don't have the "domains" option. am i missing it somewhere?

1 year 3 weeks ago
Webkilde
@Webkilde Webkilde.no

NEITHER DO I.

1 year 2 weeks ago
PhotosJo
@PhotosJo Jo Sheldrake

Have been trying all day to add the Twitter Gadget to my Blog in blogger but it is coming up with an Error message? Is is faulty or have I done something wrong? I then tried to add a twitter button direct from twitter by pasting the code into the HTML in blogger but it came up as another error? Have anyone else had this problem today? My twitter button?link from Blogger was working fine yesterday?

1 year 22 weeks ago
yazdesignz
@yazdesignz Yaz

Omg what is going on with this. They really need to change this back. Why does the code end with a script language? (See below)
I don't feel like this code is just html. It says "js" in it which is javascript

  1. <a class="twitter-timeline"  href="https://twitter.com/yazdesignz" data-widget-id="275073762213380097">Tweets by @yazdesignz</a>
  2. <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
1 year 20 weeks ago
fjmdesigns
@fjmdesigns Frank M.

I got it work! Been driving me nuts for hours!
Source path is broken....
In the line of code, add http: just before // in the source path.

  1. <a class="twitter-timeline" data-dnt=true href="https://twitter.com/fjmdesigns" data-widget-id="280686897578246144">Tweets by @fjmdesigns</a>
  2. <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="http://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
1 year 18 weeks ago
vickiejeanc
@vickiejeanc Vickie Christensen

With your suggestion it worked in Firefox. Testing further. Thank you, way to much time to fix their code? Really? You rock.
Vickie

1 year 6 weeks ago
twigcreative
@twigcreative Twig Creative

Holy crap you're my hero. You fixed it when no one at Twitter could!!! Thanks.

1 year 3 weeks ago
Believe_Designz
@Believe_Designz Believe Designz

Not a fix...

45 weeks 3 days ago
iHeavyHaul
@iHeavyHaul iHeavyHaul

I got it from one of the replies above - thank you so very much!

GOTO: Widgets, Edit and in the Domains window type: yourdomain.com , www.yourdomain.com - mine came right back up.

NICE!

1 year 16 weeks ago
Webkilde
@Webkilde Webkilde.no

And if there is no such "domain" window??.....

1 year 2 weeks ago
TroyDLive
@TroyDLive TROY D

what did we do to have to go through this why dont they want us to have this.

1 year 15 weeks ago
rummorepro
@rummorepro Rummore

i have tried everything and still not working

1 year 13 weeks ago
rummorepro
@rummorepro Rummore

ok, i have tried this and is working:

delete the // from the source like this and let the src star with: platform.twitter.....hope work for everyone else

<a class="twitter-timeline" data-dnt=true href="https://twitter.com/fjmdesigns" data-widget-id="xxxxxxxxxxxxxxxxxx">Tweets by @fjmdesigns</a>

<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>

1 year 13 weeks ago
rummorepro
@rummorepro Rummore

not allways work

1 year 13 weeks ago
55Santana
@55Santana Carlos Hernandez

Did you whistle at least?

1 year 12 weeks ago
howmindworks
@howmindworks Buddhism Update

ok it's simple. it's domain thing.
in domain area, type your domain with and without www.
for example
youdomain.com, www.yourdomain.com and it should be working.

1 year 12 weeks ago
VibeDetective
@VibeDetective The Vibe Detective

It's not simple for me - I don't see any "domain area". where am I supposed to type what you suggest?

35 weeks 17 hours ago
lennyruiz7
@lennyruiz7 Lennin Ruiz

i had the same problem and it works for me, just type both: domain.com, www.domain.com

1 year 12 weeks ago
saharisian
@saharisian Anna Harris

Thought I'd post this here in case people haven't sorted it yet. This worked for me:

  1. Change the pathway that everyone was talking about, adding the http://
  2. Enter EVERY SINGLE domain i.e. mine was www.example.blogspot.com, example.blogspot.com, www.example.blogspot.co.uk, example.blogspot.co.uk... Mine was working on my previews only because I initially had my blog previews directing to ".co.uk" and when I added the ".com" extensions too it seemed to work... Hopefully this CONTINUES to work, Twitter!!
1 year 10 weeks ago
VibeDetective
@VibeDetective The Vibe Detective

enter EVERY SINGLE domain where?

35 weeks 17 hours ago
vincentisambart
@vincentisambart Vincent Isambart

There is no need to configure domains anymore, the widget should work on any domain.

35 weeks 12 hours ago
christonacamel
@christonacamel some guy

@vincentisambart

It doesn't. HELP ME PLEASE!

10 weeks 2 days ago
we3beta
@we3beta we3create

Just to point out that the // prefix is perfectly valid syntax as per [RFC 3986: "Uniform Resource Identifier (URI): Generic Syntax", Section 4.2.] and should not be changed unless you can guarantee the protocol used for accessing the domain will always match that of the script. IE. http: https:

The // prefix simply tells the browser to access the script via the pages current protocol. If your page uses https the script path will also use https. This rule was layed out in 2005 and should be implemented in all browsers for the last 7 years.

The above problem should be solely down to the domain name whitelist.

1 year 10 weeks ago