Internal server error

varmagazine
@varmagazine VAR Magazine

I get an internal server error when I tru to upload a 'header image'. Used punnypng and yahoo smushit to shrink the file size. Same thing. Any ideas?
Thanks in advance

1 year 29 weeks ago

Replies

DominikBulaj
@DominikBulaj Dominik Bułaj

Same here. 2.79MB image (2816x2112 px) and i see "Internal server error". Tried even sign-out and sign-in again - no changes.

1 year 29 weeks ago
whenweescape
@whenweescape Meaghan Savage

500KB image does the same thing. The new feature looks great just wish I could use it...

1 year 29 weeks ago
DominikBulaj
@DominikBulaj Dominik Bułaj

Worked for me after several tries in Chrome & Firefox. It's nice, yes ;)

1 year 29 weeks ago
wertolet2677
@wertolet2677 Alexander Slesarev

YEAP.....

1 year 29 weeks ago
LazyMatios
@LazyMatios Bard of Doom

Twitter informs that the image must be lower than 5MB, but nevertheless, the image must be lower than the resolution 1200x600, so you have to resize the image you want to use. Enjoy the new feature now ;)

1 year 29 weeks ago
CuriousKarman
@CuriousKarman Karman Morey

thank you that worked for me.

1 year 21 weeks ago
suhandiwiratama
@suhandiwiratama Suhandi Wiratama 魏权汉

Thanks dude.. It works for me as I resized it to 1200x741.. the file size is 76.5 KB. Twitter is very sensitive with big size file, so the picture size should be really small. Smaller photo file size, bigger success chance.

1 year 17 weeks ago
emotionellie
@emotionellie Angeneilie (。◕‿◕。)

Same thing happens to me right now -_- my 1200x600 image is only 253KB in size. I shrunk it now to 690x345 and it's 121KB and it still won't upload.

Edit: Nvm got it to work now, with an image with the size of 76.7KB...

1 year 28 weeks ago
MSyahrulHelmy
@MSyahrulHelmy ϟyahrul ℋelmy™

Just Make Sure That You Header Size Is 1200 Width x 600 Height It Will Work Then.

1 year 26 weeks ago
varleshdhurmea
@varleshdhurmea Varlesh Dhurmea

THNX::: It was useful

1 year 26 weeks ago
Jonesey015
@Jonesey015 Bernice Jones

I just used firefox and it worked for me; got fed up trying with chrome

1 year 26 weeks ago
pulse_appx
@pulse_appx PULSE by App-X

Just got it to work with a 1200x600 jpg in Firefox.

1 year 25 weeks ago
Takao_hasiguchi
@Takao_hasiguchi Takao Hasiguchi

i changed it into jpg and finnaly worked, thanks!

9 weeks 1 day ago
jackyan
@jackyan Jack Yan 甄爵恩

Internal server error here, too, for the last two days. Gosh, I see the error is over six weeks old. :(

File dimensions are 1,252 by 626, as Twitter suggests, and the file is a tiny 316 kbyte.

1 year 23 weeks ago
MysterManager
@MysterManager Myster Manager

I created a 1200 x 600 pixel image in Photoshop as a test, uploaded it, and it seemed to work fine. Then I went back to the image, deleted the test layers and created the final version of the image. It's still 1200x600, and it's 1.3M, but every time I try to upload it I get the error.

I deleted the previous test image, so I'm just uploading a new image.

Also, I noticed that in this account I see: "Recommended dimensions of 1252×626
Maximum file size of 5MB" instead of the 1200x600 that everyone else remarks on. Not sure what the discrepancy is, but the 1200x600 did work earlier today.

1 year 23 weeks ago
MysterManager
@MysterManager Myster Manager

I just checked again.

I can upload the first, test image consistently, without any issue. It's 1200x600 and only 4k. But even when I converted the final image I want to use to a 500k GIF (which, remember, was created from the same image template that the test image came from), I get the error.

It's maddening, because it's literally the same image file with different "content" saved into two different file names. One works, the other doesn't.

1 year 23 weeks ago
MysterManager
@MysterManager Myster Manager

So I changed the NAME of the file that didn't upload from "header-image.png" to "test2.png" and guess what...Now it uploads without error.

1 year 23 weeks ago
911ca
@911ca Sandi

sooo weirdd.. but it works with this way hahaha.. from as.jpg to test.jpg. :D

1 year 4 weeks ago
MysterManager
@MysterManager Myster Manager

So I went back and made a slight modification to the image (added a gradient) which actually reduced the file size. I saved it with filename containing no hyphens, and when I tried to upload it I got the error again.

But this time I noticed that when I first tried to upload it the Design page became unresponsive after I selected the file and clicked "Apply" in the Windows dialogue box. The preview/resize screen didn't open. I closed the browser tab and came back, and when I tried to upload again I got the error. This is exactly what happened the first time I got the error.

I feel like it's voodoo or something. There's no rhyme or reason to it. Really shoddy work on the part of the developers who designed this functionality.

1 year 23 weeks ago
MysterManager
@MysterManager Myster Manager

So far the only thing that works consistently is going back and renaming the file. It's like it clears Twitter's bad memory of the file and gives it a chance to start fresh.

Same file...Just a new name...And it works. shrug

1 year 23 weeks ago
Tapjay
@Tapjay Julian Tapales

I found that using .jpg solves the problem. (I was using .png before)

1 year 22 weeks ago
wandrian
@wandrian Andy

After many retries this worked for me too ;-)
Many thanks!

1 year 19 weeks ago
analyzedwithin
@analyzedwithin Analyzed Within

Yeah, changing it to JPEG worked for me too. At first it said, Internal Server Error, but then it changed to being successful. Go figure. Just glad it finally worked.

1 year 11 weeks ago
MelvatronPrime
@MelvatronPrime Melvatron

jpg/png/bmp/gif - it matters not....

I've been playing with this for about an hour.... 1252x626 does not work.

Changed it to 1200x600 and it uploaded first time, as a png. Then sucessfully as a jpg the second.

Tested on 4 broswers...
Opera & Chrome fail... (I hear Chrome does work sometimes though)
IE9 and Firefox all good

1 year 22 weeks ago
Sajakain
@Sajakain Sajakain

My problem has been solved:

Original Image: 1252 x 626 - PNG - 1.45MB - Failed
Adjusted Image 1: 1200 x 600 - PNG - 1.45MB - Failed
Adjusted Image 2: 1200 x 600 - JPEG - 157KB - Success

I would say convert your image to a 1200 x 600 size in JPEG format and then try. If you use Adobe Photoshop I would further recommend you use the save option of "Save For Web & Devices".

I hope this helps someone else. It worked for me.

Edit: I forgot to mention that I solely used Firefox. I did not try on any other browser.

1 year 21 weeks ago
AnOrcsLife
@AnOrcsLife Grawnk

Just putting in my two cents. I had a .png image exactly 1252 x 626 but twitter would not take it. Like people said here, I changed it to 1200 x 580 something and twitter took it right away. Whatevs.

1 year 21 weeks ago
deuol
@deuol Ian Perryman

Tried renaming the image and saving for 'Web and devices' from PS.
Still didn't work.
Also notice that when I put my mouse cursor over the button I don't get the little hand symbol to show it's an active link.

1 year 21 weeks ago
deuol
@deuol Ian Perryman

Just checked out the twitter help page and it says:

To customize your header photo:
Sign in to your account.
Go to your Settings and click on the Design tab.
Scroll down to the Customize your own section.
Click on Change Header to upload a new header photo

But the Change Header button isn't under the Design tab it's under Profile????

1 year 21 weeks ago
_thp
@_thp Cptn. Tiller, Meat

This works. Thanks.

This is probably something twitter should be focused on.

1 year 21 weeks ago
AlanJEdmonds
@AlanJEdmonds Alan Edmonds

@LazyMatios - Thanks so much for this, I kept getting errors until I resized to 1200 x 600!
Previously, I'd tried 1252 x 626, because that's what it currently says on Twitter's Edit Profile screen, next to the "Change Header" button - which is clearly not correct...

1 year 21 weeks ago
GOPReason
@GOPReason Repub. Reason Caucus

I tried all of the above suggestions and none worked. Then I switched from Firefox to Chrome and it suddenly worked in Chrome on the first try. As previous commenter said, there is no rhyme or reason. Just try anything and everything until something works. Hopefully Twitter fixes this eventually.

1 year 20 weeks ago
JuicyBodyArt
@JuicyBodyArt Juicy Body Art

I tried all of the above on Chrome, Safari and Firefox over a period of 3 days. Reduced the resolution to 1200x600 - no dice. Renamed the file 4 times - no dice. Tried both png and jpg - no difference. Reduced the file size to 230KB, then 180KB, then 50KB - nothing. Back and forth with Twitter's support service yielded absolutely nothing. As a last ditch attempt at fixing it, I resized the file to 30KB and voila! The server finally accepted it.

I hope Twitter are concentrating on fixing this on their end, as it's obviously a prevalent problem.

1 year 20 weeks ago
philnash
@philnash Phil Nash

I haven't been able to upload a header image either. I've been trying through the site and the API. I hope Twitter acknowledge this soon.

1 year 20 weeks ago
Di2ifter
@Di2ifter Jeremy Fabunan

Originally I had my crop precisely set to 1252 x 626 and I tried uploading it on various browsers.
I took the advice of some people and sized it down to 1200 x 600 and uploaded it on safari and it finally worked. The file size of my banner is 270 KB.

It seems the resizing has worked for some and not others. Hopefully everyone finds a solution.

1 year 20 weeks ago
harmonicapocket
@harmonicapocket The Harmonica Pocket

Hey everyone, yes this is super confusing. Right under the "Upload Header" button the directions tell you to resize to 1252 X 626.

If you resize to 1200 X 600 the upload should work.

If you're still having problems try a different browser to upload. G'luck!

1 year 20 weeks ago
ClintEverett1
@ClintEverett1 Clint Everett

I've tried all the suggestions and still no dice for me :/

ETA: and its up now. Even though I was well under the 5MB mark every time, smaller file sizes seem to make it work. I don't know. Twitter is the one recommending large dimensions, so hopefully they'll get this bug sorted soon.

1 year 20 weeks ago
BAPboekhouding

My solution was to log out, log in. Now i could add a header, after trying almost all of the above solutions.

Unfortunately, now I decided to also change our profile picture and I had exactly the same problem. Again i logged out and logged in, and it worked... Still I find it a bit weird that a company which says it's heading for a 1 billion dollar revenue is incapable of fixing seemingly tiny bugs in their product (with probably quite a lot of dedicated developers).

1 year 19 weeks ago
dannykastner
@dannykastner Danny Kastner

It's so unreal that this elementary function craps out so much.
Summary
1) They don't test their software
2) Their software is crappy, and they don't really care

Ridiculous.
I gave up on the PNG and then made a JPG that worked.

How embarrassing is it that Twitter doesn't monitor this thread and fix this!
I guess that's why the #2 Social Network, time on site, is now Instagram, owned by Facebook - haha.

1 year 18 weeks ago
__Bradshaw__
@__Bradshaw__ elliott bradshaw

Im having the same problem, for some reason i was able to get an image that was 1920x1200 to work but cant seem to get one that is 1109 x 626 to work T-T no clue, seems kinda random to me lol!

1 year 18 weeks ago
cearls0813
@cearls0813 ❤ A Y A ❤

plzzz help me my twitter something wrong is very little image what i need to do?

1 year 16 weeks ago
StockBrain99
@StockBrain99 Robert Buran

Hey I am going crazy with this. I simply want to put my old photo, shown, up in the new header format. I have done everything from making it huge to making it tiny and all I get is a blurred nose. I realized something is wrong other than my size when I downloaded one of the pictures here of a person who said they got their picture to work in the header format (I could see his picture was in the header format clearly) and even that showed up with HIS blurred nose when I tried to make it my header! HELP. I do not know what to do next.

1 year 14 weeks ago
CAVSCarms
@CAVSCarms CAVS Carmarthenshire

Just used Chrome and uploaded 1180 x 590 - after failing with 1252 x 626 and 1200 x 600.

1 year 14 weeks ago
utilisoft_au
@utilisoft_au Utilisoft Australia

It failed for me at all sizes on FireFox on Windows . Worked fine on Safari on Windows.

1 year 13 weeks ago
utilisoft_au
@utilisoft_au Utilisoft Australia

My original image was saved in PNG format but following some earlier advice I changed it to JPEG format and then I was able to upload using Firefox on Windows at any size image.

1 year 13 weeks ago
Zuppkko
@Zuppkko Tadej Zupanc

Apparently, size doesnt matter, because i was able to upload an image of a size 1600x1200. The only problem was i couldn't change image position, because then i got this "internal error" message.

Try to stop repositioning your image before resizing it. It worked for me.

Good luck!

1 year 13 weeks ago
ngiverson
@ngiverson Natalyn Giverson

I tried every combination of renaming the image, 1252x626, 1200x600, 520x260, IE8, Firefox, JPG, etc. In the end, I renamed the 77KB (520x260) image I was using and then saved the JPG as a PNG and (miraculously!), the upload worked in Firefox.

This thing is evidently hit or miss and, based on this thread, doesn't appear to be getting better. Best of luck to you all!

1 year 12 weeks ago
AsimZaman1
@AsimZaman1 Asim Zaman

When I uploaded my photo, my profile pic didn't appear to change to the new one.
So I kept on trying and every time got the message "Internal Server Error".
So I signed out from twitter and signed in again, and miraculously my new profile pic was there on the display.

1 year 11 weeks ago
Templatefolio
@Templatefolio LimitedSystems

If you are receiving the following message (Internal Server Error) when trying to upload a header image - note the following:

  • As long as the image is the correct format PNG, JPEG etc., GIF images are not accepted for security reasons.
  • As long as the image is the correct size, under 5MB's, there is no need to resize your image(s), it will automatically be resized to fit.

THE SOLUTION/FIX:

STEP-1.) If you are changing your header image, remove the current image, now upload the new image. If you receive the Internal Server Error message, continue to STEP-2 and STEP-3.

STEP-2.) Refresh the current page with (F5) or the refresh button, then click/press the Home button (Top-Left).

STEP-3.) Click/press your site Name/link (below the Home button), in the header box press the Edit button and upload your new image.

1 year 10 weeks ago
bennyschmidt_
@bennyschmidt_ Benny

Image processing = 100% CPU. Just keep trying until @twittereng chooses/writes a more legit server app, or until cloud hosting providers step their game up.

1 year 8 weeks ago
IPlaytennis1
@IPlaytennis1 Cute ni SIYA!!!

Why is my twitter page doesn't look like twitter? No pictures do not display...

1 year 6 weeks ago