How to change the permission from read only to read/write ?

Mohamed_Zikas
@Mohamed_Zikas Mohamed sayed

i`m new to android development and i have create a twitter application to connect to be able to post on twitter application , but i have notice that the permission allowed is read only , how can i change the permission to read/write

BR

Mohamed sayed

2 years 33 weeks ago

Replies

Red_Rule
@Red_Rule R. Deckers

Got to dev.twitter.com/apps
Select your app, then under 'settings' --> 'application type' you will find what you need.

R.D.

2 years 33 weeks ago
episod
@episod Taylor Singletary

Also, you'll need to regenerate or renegotiate any access tokens you have for the application after changing the permission type. The app-level permission type only effects tokens created from that point forward, it is not retroactively applied to existing tokens.

2 years 33 weeks ago
javs2311
@javs2311 Jordano

Do you know if the old access tokens already in use will still have access (but only read) after the change is made to read/write in the application type? Or will it force them to sign in again to get new access tokens?

2 years 4 weeks ago
episod
@episod Taylor Singletary

Existent tokens will remain valid at the same level they were at before -- so they'll still be read-only until they are upgraded and continue to function for those purposes.

2 years 4 weeks ago
javs2311
@javs2311 Jordano

Thanks for the quick reply!

2 years 4 weeks ago
sudha169
@sudha169 sudha

thank you !!!

1 year 5 weeks ago
toptwetcom
@toptwetcom توب تويت

setting tab -> Application type -> Read and Write

then go to details tab -> recreate my access token button

22 weeks 21 hours ago
ErGopiSingh
@ErGopiSingh Gurpreet Singh

Thanks, I recreated tokens and it worked fine

16 weeks 1 day ago
MachoMarket
@MachoMarket Mach II Market

Excellent help guys - solved my problem and saved my sanity.

2 years 24 weeks ago
CrowdConnection
@CrowdConnection Jill Woods

I can select the read and write radio button and save the changes but the setting just reverts back to Read only when I refresh the page. How can I get over this?

Cheers - Jill

2 years 17 weeks ago
episod
@episod Taylor Singletary

It takes time for an application setting change to take effect -- wait a few minutes before refreshing the page and you'll see it change eventually.

2 years 17 weeks ago
SajidJavaid
@SajidJavaid Sajid Javed

I did exactly the same thing but still no luck. first on on error pop up twitter is over capacity please try again. When i retry successfull message appears and settings chaged under settings tab but not on detail page actually.

I wait for whole day for changes to take affect but nothing happened.
Please help.

Thanks

2 years 5 weeks ago
developmenttwbs
@developmenttwbs development

I done all as such but the tweet not appearing in the account.Can any one help me ?

1 year 36 weeks ago
amalvj123
@amalvj123 amal v j

thanks,same problem,solved

1 year 25 weeks ago
zaptest123
@zaptest123 Designer Zaptech

HI,
I got this output ......
object(stdClass)[5]
public 'request' => string '/1/statuses/update.json' (length=23)
public 'error' => string 'Read-only application cannot POST' (length=33)
-------------I provide all this keys-----------------

consumerKey , consumerSecret , oAuthToken , oAuthSecret

Your access token -----------> Access level Read-only
OAuth settings------> Access level Read and write

Thank you ,
Uresh

1 year 11 weeks ago
RenateBlaes
@RenateBlaes RenateBlaes

Yes, it takes some minutes to set the chanings. That is my experience too.

15 weeks 5 days ago
adamandham
@adamandham Adam Herbst

Is it possible to have an app that is read-write, but request a read-only token for a particular user? I know that the timeline is public anyway, but I want to allow the user to log in to Twitter to prove their Twitter identity, but not force them to allow me write access.

11 weeks 1 day ago
devpaulson
@devpaulson dev paulson

To enable write permission, mobile number need to be registered on twitter. I am an Indian and unfortunately none of my phone numbers worked on twitter. It says carrier not supported. Atlast I cant test the app. What can i do now. Is there any testing account in twitter. How to solve this?

3 weeks 6 days ago
vs25mei
@vs25mei Voorspel 25 mei 2014

Same thing in Norway. I also tried the long codes, but that didn't work either.

1 week 5 days ago
dt4wl
@dt4wl Tips 4 Weight Loss

And same problem in Australia. I've tried the long code for UK and for Germany. I've tried 3 minutes between SMSes. I've tried adding an end-of-line to each SMS.

I really hope they come up with an easier way. This is really frustrating.

6 days 18 hours ago
itsmedhinu
@itsmedhinu dhinesh

i was able to post earlier....stil i have the write access to my old app..but i am not able to use that app.i always get an error.

3 weeks 1 day ago
Sophiajoh14
@Sophiajoh14 Sophia Joahnson

it doesn't work , added my mobile number , but phew!!!

2 weeks 5 days ago
priyainfant
@priyainfant priya

i successfully run sample code in Twiiter4j,but i got error when i run Examples like Authentication credentials are missing.

anyone help me

1 week 5 days ago