Photo upload issue

bhelsloot
@bhelsloot Berry Helsloot

Our users are still experiencing issues uploading pictures with Twitter for iPhone to Moby. Any news yet ?

2 years 26 weeks ago

Replies

episod
@episod Taylor Singletary

We're investigating some issues some clients and service providers are having with OAuth Echo on iOS5. If you could assist us by evaluating your services exact logic when it comes to processing an incoming OAuth Echo request.

One difference now is that iOS may add an application_id parameter to the query string of the URL to specified in X-Auth-Service-Provider when calculating its signature base string. Some clients may not be recognizing that this parameter has been added and then neglecting to place it on the URL specified in X-Auth-Service-Provider.

Some service providers may be then in turn requesting data not from either A) the exact URL specified in X-Auth-Service-Provider (including application_id when it is present) or B) what it assumes the URL should be (a hard-coded URL to Twitter's verify credentials method).

As you can see, the issues can be both on the client side as well as the service provider side, and you may be experiencing different aspects of the issue depending on the client that's making requests through you.

Can you share exactly how your OAuth Echo requests are interpreted/processed/handled?

2 years 26 weeks ago
ifkya1957gh
@ifkya1957gh Kofi Yeboah_Agyemang

hope after one year in the wilderness the problem is solved. However, should it not be resolved then you should consider the mode the picture is saved that also determines the uploading. As PNP image or JPEG will be different from GIF animation or MPEG video when uploading for them to appear instantaneously.

1 year 24 weeks ago
adillalani
@adillalani Adil Lalani

The issue is that Twitter for iPhone on iOS5 isn't passing 'oauth_token' in the HTTP_X_VERIFY_CREDENTIALS_AUTHORIZATION header.

@episod any idea when this will be fixed?

2 years 26 weeks ago
drinks
@drinks Dan Drinkard

+1, this is a bug in the latest release of Twitter for iPhone. Looking forward to a quick update to address this :)

2 years 26 weeks ago
MeltingIce
@MeltingIce Ryan LeFevre

Can confirm this is the problem for us as well. Just logged this verify credentials header:

[HTTP_X_VERIFY_CREDENTIALS_AUTHORIZATION] => OAuth oauth_timestamp="1319056671", oauth_nonce="393XXXXXXXXXXXXXB", oauth_version="1.0", oauth_consumer_key="IQXXXXXXXXXXXXA", oauth_signature_method="HMAC-SHA1", oauth_signature="rWXXXXXXXXXXXXXXzc%3D"

The oauth_token parameter is clearly missing from the header. It's been 6 days since this bug was introduced. We're hoping there's a fix for it very soon.

2 years 26 weeks ago
episod
@episod Taylor Singletary

We're working to resolve the missing oauth_token issue with Twitter for iOS -- however, there are still some additional areas of concern with OAuth Echo on iOS5 that we're looking to resolve.

If you're an image provider that supports OAuth Echo over iOS5, please email me at episod@twitter.com -- there are some image upload providers who appear to be using hard-coded/assumed values in the verification sequence.

Thanks.

2 years 26 weeks ago
bpelgrom
@bpelgrom Bram Pelgrom

Our Mobypicture users are still having problems with uploading photos from the iOS Twitter app to Mobypicture using OAuth Echo.
I'll describe how we process the Echo authentication (using PHP):

  • We check whether the "X-Verify-Credentials-Authorization" headers are set in the request
  • If they're set, we collect the values for "X-Verify-Credentials-Authorization" and "X-Auth-Service-Provider" (case insensitive)
  • We parse_url() the "X-Auth-Service-Provider" to check whether the host-part contains "api.twitter.com" or "twitter.com" and the path-part contains "verify_credentials" - works... so far, so good.
  • Next we execute a HTTP request to the "X-Auth-Service-Provider" URL:
    1.             // These values are not hardcoded, but come from a Twitter OAuth Echo request, also note that the oauth_token value is missing :(
    2.             $echoAuthServiceProvider = 'https://api.twitter.com/1/account/verify_credentials.json';
    3.             $echoAuthHeader = 'OAuth oauth_timestamp="1318929811", oauth_nonce="1CE9530D-FE40-47A7-BF23-8154405E0606", oauth_version="1.0", oauth_consumer_key="IQKbtAYlXLripLGPWd0HUA", oauth_signature_method="HMAC-SHA1", oauth_signature="0o75mIXOw5FdACHnyKoyEPe0bik%3D"';
    4.  
    5.             $c = curl_init($echoAuthServiceProvider);
    6.             curl_setopt($c, CURLOPT_RETURNTRANSFER, 1);
    7.             curl_setopt($c, CURLOPT_FOLLOWLOCATION, 1);
    8.             curl_setopt($c, CURLOPT_HTTP_VERSION, CURL_HTTP_VERSION_1_1);
    9.             curl_setopt($c, CURLOPT_HTTPHEADER, array('Expect: ', 'Authorization: '.$echoAuthHeader, 'User-Agent: Mobypicture OAuth Echo'));
    10.             curl_setopt($c, CURLOPT_RETURNTRANSFER, true);
    11.             $result = curl_exec($c);
    12.             $status = curl_getinfo($c, CURLINFO_HTTP_CODE);
    13.             curl_close($c);
    14.  
    15.             var_dump ($result);
  • Which results in:
    '{"error":"Could not authenticate with OAuth.","request":"\/1\/account\/verify_credentials.json"}'
2 years 26 weeks ago
F9photo
@F9photo F9photo

Here is the new headers posted by iOS5 Twitter on custom image upload which fails due to lack of oauth_token. Twitter iOS4 posted the oauth_token in the X_VERIFY_CREDENTIALS_AUTHORIZATION:

oauth_token is need for oauth Echo as per https://dev.twitter.com/docs/auth/oauth/oauth-echo

Is oauth echo still supported in iOS5?

TWITTER APP iOS 5 HEADER LOGS:

[HTTP_USER_AGENT] => Twitter/3.5 CFNetwork/548.0.3 Darwin/11.0.0
[HTTP_X_VERIFY_CREDENTIALS_AUTHORIZATION] => OAuth oauth_timestamp="1318875025", oauth_nonce="FA8E28BXXXXXXXXX6A6DC", oauth_version="1.0", oauth_consumer_key="IQKbtXXXXXXXX0HUA", oauth_signature_method="HMAC-SHA1", oauth_signature="JpbqoXXXXXXXXXXA%3D"
[HTTP_X_AUTH_SERVICE_PROVIDER] => https://api.twitter.com/1/account/verify_credentials.json

2 years 26 weeks ago
F9photo
@F9photo F9photo

Has anyone heard an update yet on the missing oauth_token issue? Is it being fixed or is there another iOS5 method that exists that will allow 3rd party image uploads?

Taylor, any status update and sked fix would be great!

Thanks

2 years 24 weeks ago
episod
@episod Taylor Singletary

Hi all,

The update for Twitter for iOS should hit the App Store some time this week. This build fixes the issue where we were not sending an oauth_token, as well as a number of other fixes to our OAuth Echo implementation under iOS5.

If you're an image provider, ensure that you're flexible in your OAuth Echo implementation on accepting additional parameters in the X-Auth-Service-Provider HTTP header -- for iOS5 applications making use of TWRequest, the header will contain an additional application_id parameter which must be passed back to api.twitter.com when performing the "verify credentials" step.

2 years 24 weeks ago
F9photo
@F9photo F9photo

Thanks Taylor!!

The new 3.5.1 iOS Twitter app solved the Oauth echo implementation issue.

and a simple:
curl_setopt($ch, CURLOPT_URL, $header_request['X-Auth-Service-Provider']);
takes care of the new application_id.

2 years 23 weeks ago
stewer7
@stewer7 Sean

I can't send a photo with twitter,message says photo upload failed,could not authenticate you,header rejected by twitter.have installed latest version of tweetlist.can anyone help me,would be grateful,thanks.

2 years 23 weeks ago
sonusindhu10
@sonusindhu10 Sonu Sindhu

I want to upload photos on twitter with php api
can anyone help me regarding this

2 years 22 weeks ago
kurrik
@kurrik Arne Roomann-Kurrik

https://github.com/themattharris/tmhOAuth/blob/master/examples/photo_tweet.php contains a PHP example of posting a Tweet with a photo.

2 years 22 weeks ago
sonupnf
@sonupnf Sonu Sindhu

I have a little bit confusion about twitter photos uploading api with php

Can any one help me regarding this

Thanks so much

2 years 13 weeks ago
episod
@episod Taylor Singletary

https://github.com/themattharris/tmhOAuth/blob/master/examples/photo_tweet.php demonstrates an example of doing this in PHP -- if you need help with something more specifically, be sure and open a new thread for help.

2 years 13 weeks ago
sonupnf
@sonupnf Sonu Sindhu

Thanks for this..

But I want this .. When click a image link after click twiiter authenticate user and this picture upload his account...

Can help regarding this

2 years 12 weeks ago
sonupnf
@sonupnf Sonu Sindhu

Thanks for this..

But I want this .. When click a image link after click twiiter authenticate user and this picture upload his account...

Can help regarding this

2 years 12 weeks ago
imdanchill
@imdanchill Daniel Hill

So are you guys every going to build an API that works? You know... like Facebook's?

2 years 3 weeks ago
imdanchill
@imdanchill Daniel Hill

I've been scouring the internet now for 2 days trying to figure out how to use php to update a user's profile picture (account/update_profile_image). I'm using the EPITwitter Library and the post_accountUpdate_profile_image method that utilizes a php magic construct __call method to exec.... I receive a 200OK response, but the profile image doesn't change. As a developer that regularly has to deal with clients who "want every social network possible built into our website", I can say (and im sure a ton of others can, too) , you shouldn't put something in the API docs if it doesn't work... It's misleading and it gives us developers absolutely nothing to turn to when we need to tell our clients your API doesn't work.

2 years 3 weeks ago
antek_apink
@antek_apink alfin hansen

i can't to send anything

2 years 1 day ago
Artobaba
@Artobaba atobaba

i want to upload photo on twitter with php api

1 year 47 weeks ago
Timothy95187077
@Timothy95187077 tafric00@gmail.com

I want to upload my foto on tweeter
I dont now how

1 year 46 weeks ago
jikanshafa
@jikanshafa Jamilu Ahmad Shafa

I cannot upload a profile picture using both Mozilla firefox and internet explorer.

1 year 41 weeks ago
TrinityFLRepub
@TrinityFLRepub TrinityFLRepub

Having same problem here & I too tried using IE & Firefox with no luck. Anyone have any idea how this can be repaired?

1 year 35 weeks ago
MahaAbdulkareem
@MahaAbdulkareem Maha Abdulkareem

There is error when I upload photos

1 year 39 weeks ago
sanket27
@sanket27 Sanket Sawant

I am trying to upload image into twitter using HttpWebRequest object in ASP.NET 4.0 (C#). But I am getting error 403 forbidden request. I require it for console application.I am using upload.twitter.com site url but still it is not getting Uploaded.I have done this in PHP and now the code is migratting in .NET.

If anyone has example for uploading image using Twittersharp or any other C# console app then please reply immediatly.

Thanks Regards, Sanket

1 year 39 weeks ago
StarlineVenture
@StarlineVenture Starline Ventures

I have been trying to upload a photo using the twitter api by downloading an image to my server then posting it to twitter but I keep getting the same status error https://dev.twitter.com/discussions/9424

1 year 38 weeks ago
Haugmoen
@Haugmoen Lisa-Marie Haugmoen

I can't send photos from my camera app to Twitter anymore! It says connection to Twitter failed all the time now. What's up with that?

1 year 37 weeks ago
sonjayelich
@sonjayelich sonja yelich

did you get a response? i have the same problem.

1 year 1 week ago
Natersa
@Natersa mlantwa salomane

I can't upload my profile picture, it keep hanging or loading all de time.

1 year 37 weeks ago
Tieka_luv
@Tieka_luv TaNicca Scott

I'm having trouble loading Pictures from my cell phone.

1 year 37 weeks ago
CSACaneCreek
@CSACaneCreek Glenda Ploeger

I am not a geek; but was able to post some photos on Twitter until recently. Any idea why not now? Or how to fix??

1 year 36 weeks ago
tobynixon
@tobynixon toby nixon

Uhm I have a problem uploading pics from my phone (Metropcs) just says message sent been that way for a month. I can upload off facebook on kindle fire. But not from phone. Just so you know.

1 year 35 weeks ago
_chrissean
@_chrissean Sean Ford

My profile picture won't upload, and I am using Twitter on my computer.

1 year 35 weeks ago
TrinityFLRepub
@TrinityFLRepub TrinityFLRepub

Experiencing same issue, hopefully they'll get this corrected!

1 year 35 weeks ago
NobilityIAm
@NobilityIAm Austen Nobles

Hi, I can't change my profile picture. It's been blank like this all day. I've noticed other users have experienced this issue too. I'm very displeased and am wondering if there is anything I can do to fix it. I've tried everything. I tried uploading on both my phone and computerr yyet nothing works. Can anyone assist me?

1 year 35 weeks ago
jerrykids1
@jerrykids1 jerrykids

How can I upload my picture?

1 year 30 weeks ago
bhal8207
@bhal8207 Barry Haldane

Hi,

I am not a tech head judging by some of the techheads above lol

When i try and add a photo from my library on a tweet it states the application doesnt have access to my photos or videos. I can enable access in Privacy Settings. How can I resolve this?

Cheers ;-)

1 year 28 weeks ago
Ninja5041Favour
@Ninja5041Favour favour

thank for the answers guys

1 year 26 weeks ago
JingboyG
@JingboyG POMPEYO GARDUQUE jr

your photo uploading is like a contest

1 year 25 weeks ago
OberonBone
@OberonBone Oberon Bone

I have iPhone 5 - cannot tweet pictures. Have tried repeatedly uninstalling, logging out, etc. In settings - have no other image engines to use as alternative. Help please!

1 year 25 weeks ago
yashwant05
@yashwant05 yash

i have to upload image using c# on twitter please help with code..

1 year 25 weeks ago
Loud_nOutspoken
@Loud_nOutspoken SheActsUpp!^.^

my twitter wont allow me to upload a header!!

1 year 24 weeks ago
sugarsandphoto
@sugarsandphoto SugarSandPhotography

I can upload a picture from my iphone 4s but not from my computer (and just getting a picture off my desktop). Anyone know what's up? Have suggestions? Thanks!

1 year 13 weeks ago
jamesbibbs
@jamesbibbs James

Since the last update I haven't been able to tweet a single picture. Using an HTC One...

1 year 12 weeks ago
G1Lion4Life
@G1Lion4Life ☜ DŁiФИ ☞

Ok Ok Ok all you will need to do is download Opera or if you have two dif browsers open one , sign on to only One twitter account go through your normal ritual of choosing your background, Save. open the second browser, may it be Explore or Safari minimize and see the magic show. G14Life hit me back please if this has worked for you i have done it several times when my background has not uploaded. The two browses I use specifically is Opera and Safari signing into Opera for Twitter then opening and minimizing Safari browser.

1 year 6 weeks ago
Gogineni009
@Gogineni009 goginenichakrapani

our launched new marriage bauro.add profils

50 weeks 3 days ago
MPamellaa_
@MPamellaa_ Magdalena Pamella

Helllooo Love you

50 weeks 2 days ago
biswajit_sahani
@biswajit_sahani BISWAJIT SAHANI

Nice

47 weeks 2 days ago