Twitter Profile Widget not working

nyu_informatics
@nyu_informatics NYU Informatics

On my website the widget isn't working.

When using profile widget builder at https://twitter.com/about/resources/widgets/widget_profile, it is also not working.

Behavior occurs for my personal and public account.

Please advise.
Thanks.

2 years 18 weeks ago

Replies

_blor
@_blor blor

The same thing is happening to me. Right now it looks like most of the widgets for 'My website' except for the Search Widget aren't working.

2 years 18 weeks ago
MiamiCrepes
@MiamiCrepes Chefs Jon & Kimberly

I had the same problem. My simple fix was the address. Make sure the www. Is on your web address for your widget. Goto settings - widgets - edit - domains and check the address. MAKE SURE it is EXACT

1 year 31 weeks ago
TSCTV
@TSCTV TheSailingChannel.TV

Was testing page WITHOUT www. TWTR.Widget was blank. As soon as I added the www to the URL, back in business.

1 year 15 weeks ago
nyu_informatics
@nyu_informatics NYU Informatics

Just checked it out a few seconds ago. Appears to be fixed and working for me. See the profile widget at http://nyuinformatics.org.

2 years 18 weeks ago
_blor
@_blor blor

I just checked your site and it's not working for me. I had been looking into the "Rate limit exceeded" threads, which is the error I'm getting, but I doubt 150 people from my IP had gone to your site in the past hour - and I would think Twitter's own widget builder would not be hit 150 times from people at my IP. So I'm skeptical that's the only issue.

2 years 18 weeks ago
nyu_informatics
@nyu_informatics NYU Informatics

hmmm, where did you see the error message? I just checked my site again and it seems to be working fine. Also the profile widget builder from above is working as well.

2 years 18 weeks ago
_blor
@_blor blor

I had been seeing the error in the Net tab on Firebug. The response from the GET is

"TWTR.Widget.receiveCallback_1({"error":"Rate limit exceeded. Clients may not make more than 150 requests per hour.","request":"\/1\/statuses\/user_timeline.json?screen_name=twitter&callback=TWTR.Widget.receiveCallback_1&include_rts=true&count=4&clientsource=TWITTERINC_WIDGET&include_entities=true&1324077096143=cachebust"})"

There are a few threads on this issue here. I just find it really hard to believe that Twitter's own widget builder is falling victim to this. When I was coding my page, it worked every time, now all of a sudden it's intermittent.

2 years 18 weeks ago
nyu_informatics
@nyu_informatics NYU Informatics

is the url of your page available?

2 years 18 weeks ago
_blor
@_blor blor

This is the page I have the widget on:
http://www.tivo.com/mytivo/connect-with-us/index.html

Perhaps it is just the rate limiting - but I'm trying to figure out how I'm adding up to 150 in an hour and how to work around it.

2 years 18 weeks ago
nyu_informatics
@nyu_informatics NYU Informatics

Just visited your site. Works for me.

Perhaps the requests are getting routed through a proxy, and twitter is getting confused by the traffic coming through it.

2 years 18 weeks ago
_blor
@_blor blor

Oh that's a good point! Thanks.

2 years 18 weeks ago
almudenacv
@almudenacv almudenacv

I have the same problem you had . Could you solve the proxy traffic limitation? I have a favorite widged in an institutional page andad in all the computers of the internal net (proxy) sometimes the widget appear in blank. Thank you for your help.

1 year 13 weeks ago
ferryireng
@ferryireng ferryireng

tak mengerti akan diri sendiri

2 years 17 weeks ago
weshuang
@weshuang Wesley Huang

I am having problems too on my blog @ netdiversitiy.ca/blog.
My profile picture and text are not at same height. This is the same cut and paste code. Am I missing something else here?

2 years 17 weeks ago
jduguid
@jduguid James Duguid

Did anyone find the solution/workaround for this issue? When viewing this from a campus or large corporation, you can hit this limit pretty quickly. I'm using the list widget, which is perfect for what I need, but just keep getting the rate limit error.

2 years 9 weeks ago
episod
@episod Taylor Singletary

If you're concerned that end-users would be rate limited, your best option is to not use the widgets but instead build your own solution, likely using the Streaming API or REST polling de-coupled from direct user interaction with the sites displaying tweets.

2 years 9 weeks ago
LikesTweetsSEO
@LikesTweetsSEO David Brown

Twitter widget debugged

Removed settings checks on privacy and secure https in the Twitter account settings to get it to render again on website.maybe privacy is only needed....still checking....

2 years 9 weeks ago
OmniFilm
@OmniFilm Omni Film

I think we need to keep this thread up above.

I just made a customizable profile widget with the following code:

Put between the head tags:

!script charset="utf-8" src="http://widgets.twimg.com/j/2/widget.js"></script!

Exclamation marks are intentional to make the code appear rather than be loaded...

Put in it's seperate

<

div> on the page itself:

!script>
new TWTR.Widget({
version: 2,
type: 'profile',
rpp: 3,
interval: 30000,
width: 215,
height: 300,
theme: {
shell: {
background: '#ffffff',
color: '#707070'
},
tweets: {
background: '#ffffff',
color: '#707070',
links: '#818181'
}
},
features: {
scrollbar: false,
loop: false,
live: false,
behavior: 'default'
}
}).render().setUser('OmniFilm').start();
</script!

The box itself is loaded, but the tweets aren't appearing. I tried having both scripts in the div, but the result is the same.
Also one thing I noted was that during a re-code of the page, an error occured that messed up my menu, but then the tweets were suddenly visible... just at the wrong place.
I tried looking on different browsers through 3 different ISPs. It's the same thing all over.

I could work so well, yet causing so much trouble.

TWITTER... please respond!

website to see the problem: www.omnifilm.dk

Thank you

2 years 9 weeks ago
El_Dominicano15
@El_Dominicano15 ✪Chris Peña✪™

Can you help me with my coding? idk if it's right or not and it wont work!..

  1. <script charset="utf-8" src="http://widgets.twimg.com/j/2/widget.js"></script>
  2. <script>
  3. new TWTR.Widget({
  4.   version: 2,
  5.   type: 'profile',
  6.   rpp: 8,
  7.   interval: 30000,
  8.   width: 'auto',
  9.   height: 300,
  10.   theme: {
  11.     shell: {
  12.       background: '#00486e',
  13.       color: '#f56262'
  14.     },
  15.     tweets: {
  16.       background: '#2e038a',
  17.       color: '#05dffc',
  18.       links: '#f70000'
  19.     }
  20.   },
  21.   features: {
  22.     scrollbar: false,
  23.     loop: false,
  24.     live: false,
  25.     behavior: 'all'
  26.   }
  27. }).render().setUser('El_Dominicano15').start();
  28. </script>
2 years 4 weeks ago
dhmartin
@dhmartin David Martin

I suppose it's because of the input proxy. I have the widget in an external hosting: I can perfectly see the widget from my home computer, but no chance from our organization, inside the proxy. After reading the thread I felt quite happy to see some light in the tunnel... :))

Even better. I was moving options and changed the "profile" setup to a "search" setup, and tried to look for @twitteruser AND THIS WORKS FINE and displays all recent tweets. Hope it helps!

David

2 years 3 weeks ago
PrimorisFinPlan
@PrimorisFinPlan Benjamin Irons

Mine is not working either!

!script charset="utf-8" src="http://widgets.twimg.com/j/2/widget.js"></script!
!script!
new TWTR.Widget({
version: 2,
type: 'profile',
rpp: 4,
interval: 30000,
width: 250,
height: 406,
theme: {
shell: {
background: '#a4afc6',
color: '#000000'
},
tweets: {
background: '#dbd4db',
color: '#000000',
links: '#005eff'
}
},
features: {
scrollbar: false,
loop: false,
live: false,
behavior: 'all'
}
}).render().setUser('PrimorisFinPlan').start();

on www.primorisfinancial.com.au?

I've re-done it a couple of times and I just get a box with no tweets in it!? Help!!

2 years 2 weeks ago
kurrik
@kurrik Arne Roomann-Kurrik

The widget appears to be loading correctly for me. Maybe you've hit the 150 anonymous requests / hour limit from your IP address? Does switching IPs or waiting an hour help?

2 years 2 weeks ago
MrAlexbross
@MrAlexbross Alex Batres

No creen que sera por una falla de el widget? o que los códigos no son compatibles...? o que no son los correctos? o que su sistema es muy o poco avanzado para poderse cargar? la verdad si me funciona... pero algo debió pasar que ustedes no lo puedan poner...

2 years 2 weeks ago
RideauCanFest
@RideauCanFest RideauCanalFestival

The twitter widget is not working on our website http://www.rideaucanalfestival.ca/index.html

2 years 1 week ago
TailorMadeTour1
@TailorMadeTour1 Tailor Made Tours UK

I am having the same problem and the codes pasted above are all similar to mine.

I am putting the <script charset="utf-8" src="http://widgets.twimg.com/j/2/widget.js"></script> bit in the head section and the rest inside a <div> </div> on my website but nothing is appearing.

I have tested the div by putting a border on it and I can see where the twitter feed should be, but nothing.

Any twitter devs here to help? I havent seen any repsonse from them yet?

Thanks

1 year 48 weeks ago
Xisbi_jamhuuri
@Xisbi_jamhuuri Xisbi_jamhuuri

I ali mohamed nuh (timajilic) the viece chairman of the united somali republican party(usrp) leaving in mugadishu s o m a l i a.

1 year 48 weeks ago
Xisbi_jamhuuri
@Xisbi_jamhuuri Xisbi_jamhuuri

I want wedget profile with working.

1 year 48 weeks ago
Isphaa
@Isphaa Spha Salathiso Blou

damn seemingly we all having the same problem. i hate wasting my time on something i shouldnt

1 year 48 weeks ago
Isphaa
@Isphaa Spha Salathiso Blou

lol actually mine just worked. funny and perculia concurrently

1 year 48 weeks ago
Wallids
@Wallids wallid Salmomn

Anyone found an answer to this yet? I had a widget that did work, but now it doesn't. could it be an active X issue?

1 year 46 weeks ago
Clark_Marketing
@Clark_Marketing Scott Clark

The Twitter API has been recently updated and this started to affect some of our WordPress websites that use the GoodLayers Twitter Widget. It seemed to be affecting other twitter widgets as well.

We've found a solution that fixes it. Hopefully this helps:
http://www.clarkcommunications.ca/wordpress-twitter-widget-not-loading/

1 year 25 weeks ago
Clark_Marketing
@Clark_Marketing Scott Clark

The Twitter API has been recently updated and this started to affect some of our WordPress websites that use the GoodLayers Twitter Widget. It seemed to be affecting other twitter widgets as well.

We've found a solution that fixes it. Hopefully this helps:
http://www.clarkcommunications.ca/wordpress-twitter-widget-not-loading/

1 year 25 weeks ago
MeyerMCJ
@MeyerMCJ Catherine J Meyer

mine started working yesterday until about an hour ago. go figure.

1 year 45 weeks ago
hiinxy
@hiinxy Dave Hinxy

I use this twitter widget across a dozen different websites, some as plugins via wordpress that call this same code, as of 2 days ago every one of the sites has started to scroll tweets intermittently regardless of the servers, plugin versions or browsers. Obviously this leaves the pages with big blank boxes for periods of time. Has anyone figured out the cause of this? Devs, could you kindly provide some answers? Are you running updates that are effecting the widget_profile temporarily or is this a permenant issue you are leaving us to resolve? Some kind of clue might be useful to all the guys with the same isssues. Many thanks

1 year 45 weeks ago
supportists
@supportists Supportists

same here. Suddenly (i.e. they worked the last time I checked) they don't show at all.
When I go to https://twitter.com/about/resources/widgets/widget_profile the preview is working, but when I copy/paste the code into my site it's not working at all now. Nothing shows up.

1 year 45 weeks ago
supportists
@supportists Supportists

I've got it working - it no longer seems to like the auto width feature.

http://b143apps.com/twitter.html

1 year 45 weeks ago
IAGSDC
@IAGSDC IAGSDC Square Dance

I have width specified, and all my parameters appear the same as yours, but it still isn't working for me http://iagsdc.org - I just get a blank frame.

1 year 45 weeks ago
unigianca
@unigianca giancarlo zambù

i use widget profile and i see just my own tweets, i don't see any tweets from other people who tweets about the same thing. is that normal?

1 year 44 weeks ago
DarrenTessitore
@DarrenTessitore Darren Tessitore

just had the same problem. Make sure your tweets are not on private. Turned off private and it started working perfectly.

1 year 42 weeks ago
SocializeStatus
@SocializeStatus Socialize&#039;s Status

Just starting getting the same problem. Not only is my website not rendering the widget, but the Twitter dev site is not rendering it either: http://cl.ly/1a3A1m3d0N3Y1C152K2S

1 year 42 weeks ago
loopion
@loopion ...loopion...

We are encountering the same issue here.
- Profile tweets I want to display is not private

1 year 40 weeks ago
Wired_Society
@Wired_Society WiredSociety

wiredsociety.tumblr.com just keep getting hmmm an empty timeline that's weird.

1 year 32 weeks ago
LeesTravelGuide
@LeesTravelGuide LeesTravelGuide

anything new on this?
I'm having the same problem

1 year 31 weeks ago
davidgogel
@davidgogel David Gogel

My problem was related to a Firefox add-on: DoNotTrackPlus
After making an adjustment to that - the widget is working fine.

1 year 31 weeks ago
pulearns
@pulearns PU Learning Series

Beyond frustrated... This has worked wonkily for ages - sometimes it's there, sometimes not. It's been dead for days. Have tried in various environments - same results. I changed to https, which helped the widget to render in Chrome, when it had not. However, it is still empty. My code:

new TWTR.Widget({
version: 2,
type: 'search',
search: 'pulearns',
interval: 6000,
title: 'We get by with a little help from our friends!',
subject: 'PU Learning Series on Twitter!',
width: 500,
height: 250,
theme: {
shell: {
background: '#ff9933',
color: '#ffffff'
},
tweets: {
background: '#ffffff',
color: '#444444',
links: '#1985b5'
}
},
features: {
scrollbar: true,
loop: true,
live: true,
hashtags: true,
timestamp: true,
avatars: true,
toptweets: true,
behavior: 'default'
}
}).render().start();

This worked for a long time. Any updates???

1 year 31 weeks ago
bashar042
@bashar042 A Bashar

new TWTR.Widget({

version: 2,

type: 'profile',

rpp: 4,

interval: 6000,

width: 216,

height: 300,

theme: {

shell: {

background: '#ffffff',

color: '#292b2c'

},

tweets: {

background: '#f6f6f6',

color: '#292b2c',

links: '#1388d2'

}

},

features: {

scrollbar: false,

loop: false,

live: true,

hashtags: true,

timestamp: true,

avatars: false,

behavior: 'all'

}

}).render().setUser('bashar042').start();

Just copy and run this code. :)

1 year 31 weeks ago
pulearns
@pulearns PU Learning Series

Thanks, bashar042 - I changed the type from search to profile right after I posted here and it started working again.

1 year 30 weeks ago
bfluzin
@bfluzin Baptiste Fluzin

Same problem here, it's driving me crazy, depending on the user name, the twitter widget seems to work or not. Obviously I didn't tried on protected accounts...

1 year 31 weeks ago
BabyOneDollar
@BabyOneDollar AdorableQuotes

My twitter isn't working. When I click create widget , this was happened to me ---> Unable to save your widget, please check your inputs. I need help.

1 year 30 weeks ago
salah_vip
@salah_vip Salah Abd elhamed

@BabyOneDollar write your website address correctly ,ex www.google.com

1 year 30 weeks ago