Twitter integration with ios 5

bob_zone
@bob_zone Bobby Hartanto

Is there any login sheet for user that not yet registered their account?...
Thanks

2 years 15 weeks ago

Replies

aburodina
@aburodina رامي بارشيد

no

2 years 15 weeks ago
theSeanCook
@theSeanCook Sean Cook

There are no UI elements in the Twitter framework except the Tweet Sheet (TWTweetComposeViewController). The Twitter login UI is in the device's Settings application.

The recommended approach:
You can check if the user is already logged in via a call to +[TWTweetComposeViewController canSendTweet]. If this call returns false, the system will instruct the user to go to Settings.app and enter credentials when you call -[ACAccountStore requestAccessToAccountsWithType:]. In Settings, the user can signup or enter his or her credentials but unfortunately, the user is not redirected back to your app after logging in. As such, you may want to message the user to let them know to return once they have added an account.

It is still possible to create your own login sheet and then create the ACAccount instance for the user, but you will need to design and implement the login screen.

2 years 15 weeks ago
swaroopkeloth
@swaroopkeloth swaroop

It is still possible to create your own login sheet and then create the ACAccount instance for the user, but you will need to design and implement the login screen.

How can I set username ,password ?

1 year 49 weeks ago
14lox
@14lox Dai Hovey

Hey Sean,
You say "the system will instruct the user to go to Settings.app" where / when does it do that? I wish it did, but I can't get it to...
Are there any code examples of the Add Account section within the Twitter app?
Thanks
D.

1 year 42 weeks ago
realthinksrl
@realthinksrl Realthink

Sean, is it possible to make a TWRequest without using credentials saved in ACAccount? I have my application with key, secret key, ecc., but I don't want to save credential in a Twitter Account under "settings.app".

2 years 9 weeks ago
akonakov
@akonakov Aleksandr Konakov

I can't sign in to my Twitter account in iOS 5 simulator (Xcode 4.3.1). After verifying it shows the error message "The user name or password is incorrect". And I see this in the console:

12.02.12 2:07:53,777 twitterd: New ACAccountAuthenticator connection
12.02.12 2:07:54,979 twitterd: Error: The operation couldn’t be completed. (NSURLErrorDomain error -1012.)

How can I solve this problem? Thank you.

2 years 6 weeks ago
theSeanCook
@theSeanCook Sean Cook

Were you able to get this issue resolved? If not, please try to reset the simulator and then re-add your Twitter credentials.

2 years 5 weeks ago
_sideshow
@_sideshow Adam

This does not work. I have tried on iOS 5.0 & iOS 5.1 simulators. Resetting them both and changing the region/time zone with no luck. The error i get is "The username or password is incorrect". The system console shows "Preferences: unexpected error on accountauthentication connection"

2 years 3 weeks ago
kreeble
@kreeble kreeble

I encountered the same problem and was able to resolve it by syncing my OS X date and time settings back with Apple's servers and restarting the simulator. I had changed it earlier to simulate a different time in the app.

2 years 2 weeks ago
paulgoade
@paulgoade Paul Goade

I'm still seeing this issue (running Mountain Lion 10.8 and using Xcode 4.4 4F243). I never had this issue using Xcode 4.3.3 on Lion 10.7.

I have tried to "Reset Content and Settings..." from the iOS Simulator (I've used both version 5.0 and 5.1 for iPhone and iPad), but I still get the error "Error Signing In - The user name or password is incorrect". I've also tried turning off OS X date and time setting and back on to use Apple's time servers and restarting the iOS Simulator.

Steps:
1. Run iOS Simulator (using Hardware Device iPhone, Version 5.1 9B176)
2. Go to Settings / Twitter and enter my user name and password (the same combination works in Safari and I can successfully log in to Twitter.com)
3. Click the Sign In button

I still get "Error Signing In - The user name or password is incorrect".

Got any other other suggestions or solutions?

1 year 40 weeks ago
theSeanCook
@theSeanCook Sean Cook

I'm not sure if Mountain Lion may be the culprit here--or just a red herring--but I'd recommend trying to reset your simulator's local state and seeing if that helps to clear out whatever the problem may be. I do that using bash script below. NOTE: THIS WILL ERASE ALL OF YOUR LOCAL SIMULATOR DATA.

Are you able to login via Settings.app on a physical device?

Anything on your network in your network configuration that may be affecting the SSL connection from the simulator? Anything proxying the traffic?

  1. #  Resets all local iOS Simulator states.  Use at your own risk.
  2. #!/bin/bash
  3. rm -rf ~/Library/Application\ Support/iPhone\ Simulator//Applications//{Documents,Library,tmp}
  4. rm -rf ~/Library/Application\ Support/iPhone\ Simulator/*/Library/{Caches,Preferences}
1 year 40 weeks ago
paulgoade
@paulgoade Paul Goade

I reset my simulator's local state per your script, ran the app in the iPhone 5.1 Simulator, and still get the same issue "Error Signing In - The user name or password is incorrect" when attempting to Sign In in the Simulator Settings.app.

I am able to sign in via Settings.app on any physical device.

Nothing in my network configuration was changed (unless Mountain Lion installation changes these), and I don't have any proxies enabled.

I think it's time to hit up the Apple folks in the Developer Forums...

Thank you Sean.

1 year 40 weeks ago
emarashliev
@emarashliev Emil Marashliev

Can you give us link in the Developer Forums please , because I have the same issue , thanks :)

1 year 37 weeks ago
Demonic_BLITZ
@Demonic_BLITZ Bilal S. Sayed Ahmad

I am also having the same issue with Signing in on the simulator, Running Mountain Lion GM with Xcode 4.4 GM. Tried doing a fresh install of OS X and a fresh download of Xcode and no difference. I ran your script and its still returning: "Error Signing In - The user name or password is incorrect".

The Console says:

7/16/12 10:39:43.602 AM Preferences[2236]: Unexpected error on AccountAuthentication connection

I never had this issue in 10.7 with Xcode 4.3

1 year 40 weeks ago
ptsguylaine
@ptsguylaine guylaine

en français please

1 year 40 weeks ago
ekurutepe
@ekurutepe Engin Kurutepe

Same issue here. Just installed Mountain Lion GM and XCode 4.4 GM. Can't login to twitter with the iOS simulator.

1 year 39 weeks ago
Demonic_BLITZ
@Demonic_BLITZ Bilal S. Sayed Ahmad

Oddly enough I installed the Beta version of XCode and can only log into Twitter on the iOS 6 emulator....this is really weird...

1 year 39 weeks ago
paulgoade
@paulgoade Paul Goade

Yes - I also can use Xcode 4.5-DP3 and iOS 6 Simulator and it works to login to Twitter using the Settings.app.

1 year 39 weeks ago
Demonic_BLITZ
@Demonic_BLITZ Bilal S. Sayed Ahmad

Just as a heads up, the new version of XCode release to the general public today has the exact same issue. Something seems to be broken with the iOS 5.X SDK in ML from what I figure

1 year 38 weeks ago
deeje
@deeje deeje

fwiw, I'm seeing this as well: Mountain Lion + Xcode 4.4 + iPhone simulator + Twitter = :-(

1 year 38 weeks ago
paulgoade
@paulgoade Paul Goade

Me too...still.

1 year 38 weeks ago
Coalla
@Coalla Coalla Bio Agency

Hi guys,

There is a website and its iphone-client. Users should have ability to register/login on this service using their twitter account. There is no problem with web-client, but I have some doubts regarding iOS. I see following way:
Iphone app should get access token using reverse auth and send it to web-server. After that web-server can access user's twitter data and match this user with existing ones and register this user in case matching not found.

Is it correct? Is reverse auth the only correct way to make it? Please advise.

1 year 38 weeks ago
Coalla
@Coalla Coalla Bio Agency

I've transfer my question to new topic https://dev.twitter.com/discussions/9601

1 year 38 weeks ago
tarnfeld
@tarnfeld Tom Arnfeld

Hmm. I'm having the exact same issues, the response comes back so fast its almost as if it doesn't hit the network... I also get the following error when trying to request access to the twitter accounts via the Accounts framework....

  1. Error Domain=XPCObjectsErrorDomain Code=2 "The operation couldn’t be completed (XPCObjectsErrorDomain error 2.)"

Anyone having any luck?

1 year 38 weeks ago
BenjaminAppDev
@BenjaminAppDev Benjamin AppDev

Hi everyone,

I also have these problems :

  • when trying to add an account in the simulator :

"Error Signing In - The user name or password is incorrect" + "Unexpected error on AccountAuthentication connection" in the console

  • when running the app :

"XPCObjectsErrorDomain error 2"

Mountain Lion + Xcode 4.4

Has anybody found a solution yet please ? it is very annoying, I can't continue to work :(

Thank you.

1 year 38 weeks ago
testsoft8
@testsoft8 test

I have the same problem. IT IS NOT WORKING IN IPHONE/IPAD SIMULATOR..

OS MOUNTAIN LION
XCODE 4.4.1
SDK 5.1

1 year 33 weeks ago
picTalents
@picTalents PicTalents

Hi, same here...
. Mountain Lion
. XCode 4.4
we cannot log in to Twitter via the account settings of Xcode's iOS simulator, therefore no application integrating twitter can be tested.
Can anyone please post link in apple dev forum?
Edit: here https://devforums.apple.com/message/708341

1 year 37 weeks ago
BenjaminAppDev
@BenjaminAppDev Benjamin AppDev

same issue with Xcode 4.5 DP3 on the 5.1 simulator but works when using IOS 6 simulator, so I guess the 5.1 simulator is somehow "broken"

1 year 37 weeks ago
brentjanderson
@brentjanderson Brent Anderson

Same here, Mountain Lion XCode 4.4.

1 year 37 weeks ago
nlyrics2
@nlyrics2 Eric Cheng

Same here, Mountain Lion with Xcode 4.4. Really sad

1 year 37 weeks ago
garrettmurray
@garrettmurray Garrett Murray

Xcode 4.4.1 was just released, has anyone tested to see if Apple fixed this? I haven't had a chance.

1 year 37 weeks ago
andri_yadi
@andri_yadi Andri Yadi

Too bad, the issue is still there in 4.4.1. Can other confirm?

1 year 36 weeks ago
propjames
@propjames James Martinez

I confirm that it is still an issue.

1 year 36 weeks ago
SujanChristo
@SujanChristo Sujan Christo

Yes, this still persists :(

1 year 36 weeks ago
ayushchd
@ayushchd Ayush Chaudhary

Any solution yet? Cannot add a Twitter account from the iOS Simulator

1 year 35 weeks ago
robertsky_
@robertsky_ Robert Sim

I can create a Twitter account through the simulator. However, the return message is false even though the email was sent to confirm the creation. I cannot login as through the simulator as well.

1 year 35 weeks ago
srikanthvts
@srikanthvts Srikanth Pola

I am using twitter framework in ios5 in my app,
it is working fine and in my iPad i am login with two twitter accounts and at the time of tweeting i can switch one user to another,
my problem is how i can get which user is tweeted

1 year 35 weeks ago
WeAreSopapo
@WeAreSopapo Sopapo Productions

As of today still cannot sign in to Twitter from the iOS Simulator with XCode 4.4.1 on OS 10.8.1 (Mountain Lion).
I get the "Incorrect username or password" message.

IS THERE A FIX YET?

1 year 32 weeks ago
mweissie
@mweissie Matthew Weiss

I have the same issue and looking around I see no mention of a fix anywhere. I guess it is not fixed and not just my problem.

1 year 32 weeks ago
bladebunny
@bladebunny Tim Brooks

Wondering if this has been deprecated on the Twitter API side? I know I am also using the correct credentials, have reset the simulator, etc....Completely jumping to conclusions here but wondering if this has anything to with the recent announcements vis a vis client apps and the API?

Have just bought and have been working thru an excellent book on iOS development (iOS SDK Development from Pragmatic Programmers) -- but unable to get past the second chapter due to the Twitter client in the Simulator no longer working (Xcode 4.4.1, Mountain Lion)....

I'm hoping this is just a really bad coincidence because the alternative explanation would be, well, disappointing to say the least.

1 year 31 weeks ago
theSeanCook
@theSeanCook Sean Cook

This is most definitely NOT the result of, or in any way related to, API v1.1 or any of our recent announcements re: clients. We've notified Apple of this and I recommend that you file a bug at https://developer.apple.com/bugreporter/ to help them better understand the issue.

I also recommend trying out the most recent GM of Xcode available at developer.apple.com to see if it fixes the issue for you.

And good luck with iOS. It's an amazing platform.

--Sean

1 year 31 weeks ago
bladebunny
@bladebunny Tim Brooks

Thanks for the response. I created a Radar with Apple. Hoping the imminent iOS 6 SDK release resolves this....

1 year 31 weeks ago
b_ambili
@b_ambili ambili b

Is there any way I can retrieve user's email Id via API? I am looking forward to implement in iOS.

1 year 31 weeks ago
b_ambili
@b_ambili ambili b

How does instagram invite friends from Twitter contact? Is invitation sent to their email account?

1 year 31 weeks ago
RonCrocker
@RonCrocker Ron Crocker

I was having this same problem with iOS 5 simulator, but iOS 6 simulator seems to work fine. Literally, changing the target from iPhone 5.1 Simulator to iPhone 6.0 Simulator in Xcode 4.5 GM and re-running the app allowed it work.

1 year 31 weeks ago
vishnu786143
@vishnu786143 vishnu

like tweet how to follow us in twitter in iOS 5 simulator can u please help me in this

1 year 26 weeks ago
tapashm42
@tapashm42 TAPASH MOLLICK

Hi I am very new to ios.
plz Can i get help to find twitter follower list .

1 year 13 weeks ago
ibrahim60951788
@ibrahim60951788 ibrahim60951788

i thanks and pray in advance.

1 year 13 weeks ago
javifernandezr
@javifernandezr Javier Fernández

I have the same issue at iPhone Simulator v6.0(358.4) and OS X 10.8.2 (12C2034) ... "The user name or password is incorrect": any idea???

1 year 4 weeks ago
aneesha_m
@aneesha_m Aneesha Mathew

Change the simulator OS (say from iPhone Simulator 6.1 to iPhone Simulator 5.1 or any other one), Its a OS+Simulator Bug.

1 year 4 weeks ago