Issue #280: Not a valid URL format - when trying to create a new application

starlite
@starlite Laura Starrs

This was reported 3/15 by another user, then resolved as "not an issue" with the request to be moved to a discussion.

It is still a problem. I have attempted to create a new application with multiple variations of valid, fully qualified urls -- even going so far as to attempt "http://google.com" -- and it is still rejected. If Google is not a valid website, I am not sure what qualifies! :)

2 years 3 weeks ago

Replies

episod
@episod Taylor Singletary

Thanks for the report, Laura.

So we can understand the exact specifics here -- can you retrace your steps:

You go to dev.twitter.com/apps you click on create an app... what exact data do you put in both the Website and Callback URL fields? (Both require explicit URLs, but you can leave callback URL blank). The website field is required.

2 years 3 weeks ago
sp1n3mobile
@sp1n3mobile sp1n3 mobile

Let's say i have these filled in, what's wrong, why not a valid URL?
app name: sp1n3.tweetz

WebSite: http://sp1n3.com/

CallBack URL: sp1n3:/// (also tried sp1n3://callback, sp1n3:///callback)

2 years 2 weeks ago
episod
@episod Taylor Singletary

We will not accept non-HTTP or non-HTTPS URLs on the form on dev.twitter.com -- you could use such custom URI schemes dynamically on the oauth/request_token step of OAuth, provided you place a HTTP or HTTPS based placeholder in this field.

2 years 2 weeks ago
PragerMicro
@PragerMicro Prager Microsystems

I've tried creating an app also and every single time, it tells me my URL isn't valid. I've left it blank, I've tried it with http:// and I've tried it without http://. How do I resolve this?

2 years 1 week ago
dchathurangat
@dchathurangat Chathuranga Tennakoo

i am also still facing this problem...

32 weeks 1 day ago
a1partyrental
@a1partyrental A1 Party

I am also having this issue with a regular http:// URL

HElp!

2 years 6 days ago
dshashikumar7
@dshashikumar7 shashi kumar

iam also getting the same problem
Please resolve it fastly

1 year 47 weeks ago
evanmoran
@evanmoran evanmoran

For people still having issues with this both your website and the callback url need "http://" in front. So this worked for me:

Website: http://example.com
Callback URL: http://example.com/auth/twitter/callback/
(the exact path is up to you)

Hope that helps!

1 year 46 weeks ago
calintsz
@calintsz 곽보현

Thanks! It worked.

1 year 1 week ago
TringFinance
@TringFinance TringFinance

Thanks Man....You gave with Example.....This what is missing from all the replies...for a non technical person like me...

44 weeks 6 days ago
ShivarajRH
@ShivarajRH Shivaraj RH

Why not the twitter developer specify this error with example while creating app? It will help for new developers.

33 weeks 5 days ago
CHOIShomeschool

THANK YOU!!!! THANK YOU! THANK YOU!!!! This worked.

30 weeks 4 days ago
dheerajk809
@dheerajk809 Dheeraj Chaudhary

can please tell me in detail about this path
that what is this path /auth/twitter/callback/
and what i put in callback url in mainactivity
please help me i am new in twitter login..............

28 weeks 6 days ago
MesozZ
@MesozZ Mesut Öztürk

Just changed my browser from Firefox to IE9, the problem has been resolved.

1 year 36 weeks ago
lukejeff
@lukejeff Luke Jeffery

That was my issue too! I can't believe it. Was using chrome - kept getting the 'invalid URL' error message - changed to ie9 & it worked.

1 year 1 week ago
FrancisPang
@FrancisPang Francis Pang

Yes! Switched to IE9 and everything is already now!

3 weeks 5 days ago
seln_brasil
@seln_brasil SelnBrasil

Guys I just figured it out I was having the same issue...If you say you that ur website is the same as the callback. When I copied and pasted my callback there was an extra space highlighted. That messed up the whole thing. Try checking that. When I did that it worked out great. It almost impossible to notice, but try re-copying and pasting and being very careful, that should do it.

1 year 31 weeks ago
giacomobressa
@giacomobressa Giacomo Bressa

Awesome, that was my issue. Well done, thanks for sharing.

1 year 9 weeks ago
loinguyen261
@loinguyen261 loi nguyen

It helps me. Thanks

1 year 3 weeks ago
shp0ngler
@shp0ngler Mate Antičević

Thanks a bunch. I can't believe how stupid it is. And they STILL didn't fix it.

51 weeks 1 day ago
jpladani
@jpladani Jayshit Ladani

How can i set my localhost url while i am still in development phase? it does not accept urls like below.

http://localhost:12345
http://127.0.0.1:12345

Please help.

1 year 31 weeks ago
budsyremo
@budsyremo gagan

would really like the solution for this . It's very frustrating . You people don't pay attention to the issues or what ?

1 year 26 weeks ago
upendra_panwar
@upendra_panwar Upendra Singh

It seems like this problem just never goes. Getting sick of it.

1 year 22 weeks ago
coolbaski
@coolbaski baskar

http://localhost is not working. How to set this?

1 year 20 weeks ago
episod
@episod Taylor Singletary

You cannot input "localhost" on the form itself. Use a publicly-accessible "placeholder" URL in this field and then use localhost as your explicit oauth_callback when actually working with the API.

1 year 20 weeks ago
testsharath123
@testsharath123 testsharath123

i cant understand . can you give an example?

33 weeks 6 days ago
trebsirk
@trebsirk David Wright

The caption says I can leave the callback URL field blank, yet when I click to create my application it says "Not a valid URL format." How is this possible?

1 year 13 weeks ago
episod
@episod Taylor Singletary

Have you filled in the other fields that are asking you for a URL?

1 year 9 weeks ago
ShivarajRH
@ShivarajRH Shivaraj RH

Why not the twitter developer specify this error with example while creating app? It will help for new developers.
Or Change the validation to accept all user formats with some limits.

33 weeks 5 days ago
StashTechonlolg
@StashTechonlolg Stash Techonlolgy

Invalid URL format for my localhost
http://localhost:8582

46 weeks 2 days ago
episod
@episod Taylor Singletary

Use a different host as your placeholder then use that dynamically on the oauth/request_token step.

46 weeks 2 days ago
ranganath926
@ranganath926 Ranganath

pls send valid url

46 weeks 1 day ago
codersjunto
@codersjunto Paul J Barrett

This is such bs. I have tried everything and I know that I don't have a space at the end. I even put in http://www.google.com and it won't take it but as a person that enters google website daily I can pretty much guarantee that http://www.google.com is a valid url. Which means the other urls that I can get to for my app in my browser are also valid. They have something broken in the validation and are just not putting any resources on find the problem and fixing it. There are multiple threads and complaints about this issue.

45 weeks 2 hours ago
cometking
@cometking cometking

someone fix this damn thing. This is just stupid!!!

40 weeks 3 days ago
neerajsinghsonu
@neerajsinghsonu Neeraj Singh

Hi All,

There is no such issue in Twitter App form. It's just stupid thing that we are submitting invalid url in 'Organization website:' e.g. Organization website: 'My Company' :)

Please, fill here a valid url and you will be cool always :)

Error coming because of that field....

38 weeks 4 days ago
cap3618
@cap3618 조남선

What is my callback url.I'm going to registered api.twitter.com/oauth/request_token.
But they request my callback url.

33 weeks 6 days ago
alpha_wm
@alpha_wm alpha-it-wm

1.set url as http://yoururl/
2.do the same with callback url
3.it is ok now...

33 weeks 1 day ago
JimODonnell2
@JimODonnell2 Jim O'Donnell

That doesnt work either.

22 weeks 4 days ago
DarInsights
@DarInsights Dar Insights.

Hey y'all

Leave the call back URL empty and all will work.

haha

33 weeks 1 day ago
JimODonnell2
@JimODonnell2 Jim O'Donnell

No. It doesnt.

22 weeks 4 days ago
dheerajk809
@dheerajk809 Dheeraj Chaudhary

http://example.com/auth/twitter/callback/
can please tell me in detail about this path
/auth/twitter/callback/
please.......

28 weeks 6 days ago
balochistanchro
@balochistanchro BalochistanChronicle

Its not working , it shows a message of not a valid url format. how to fix????

26 weeks 10 hours ago
planctus_
@planctus_ davide ferrante

Same for me with firefox for linux, almost unbelievable...

23 weeks 12 hours ago
JimODonnell2
@JimODonnell2 Jim O'Donnell

No matter what I try I still get the "not a valid url format".

What up? Frustrating as hell to try to do something this simple and it becomes so complicated.

Now it says this website (my own site) has already been take for another app....so I go to my applications page and find that ... I dont have any applications. So what app has it been taken for? Its my own damn site?!?!

22 weeks 4 days ago
jonclement
@jonclement jonclement

Didn't work in Chrome, worked in FireFox

19 weeks 5 days ago
1234_kirti
@1234_kirti Kirti

I tried all solutions mentioned above.
But no one is working for me...
any other solution ????

18 weeks 6 days ago
trendlrInc
@trendlrInc Moses Ayankoya

I need someone to tell me how i can able to redirect my access token back to my iOS application when user sign-in to twitter API.. I mean if someone could tell me how i can able to set up my twitter callback url at the setting and how to configure my URL Scheme .. I need someone .. pls help me in any way .. thank you ..

12 weeks 2 days ago
Happy54793562
@Happy54793562 Happy

Tried all options given above. System reports "Not a Valid URL format". Frustrating ..... Some one @ twitter ..... Pls fix this

12 weeks 1 day ago
koombeatest
@koombeatest Koombea Tester

This is still happening. Is this service really working?

11 weeks 1 day ago
YmslilabYmsli
@YmslilabYmsli ymsli

please provide the solution for "Not a valid URL format".

10 weeks 6 days ago